Sommario

Il modulo applicativo offre servizi di sicurezza a livello funzionale.


Consultazione del Log sui dati

(Log Viewer)

La seguente funzione abilita la possibilità di ricercare sul log tutte le operazione effettuate nel tempo sulle tabelle e sulle colonne che sono state abilitate per la generazione del Log.

Questa funzione, impostando dei parametri di selezione, permette di ricercare all’interno del log le operazioni che sono state effettuate dai diversi operatori su determinati record.

La funzione è suddivisa in due parti . La prima permette di impostare i parametri di ricerca all’interno del Log. I parametri di ricerca sono l’Utente, le Tabelle , la tipologia di operazione (Inserimento, Aggiornamento, Cancellazione) e da data a data per un determinato periodo di tempo.

Di default nessuno di questi parametri sono impostati. La zona inferiore contiene le colonne su cui è possibile effettuare la ricerca su una specifica tabella. Se non viene specificata nessuna tabella in particolare (tutte le tabelle) la zona sottostante non viene abilitata, Una volta selezionata una tabella le colonne che vi appaiono sono quelle impostate nella colonna “Idx” della funzione di abilitazione del Log.

In alto a destra viene visualizzato il periodo di tempo presente nel log in linea sul database.

Una volta impostati i parametri di ricerca si può selezionare “Esegui ricerca” per ricercare i dati voluti.

Effettuata la ricerca viene presentata la seguente maschera che è suddivisa in due parti.

La parte superiore contiene le operazioni che gli operatori anno effettuato sulle tabelle visualizzando il tipo di operazione effettuata (I=Inserimento U=Aggiornamento D=Cancellazione) il nome della tabella sul quale è stata effettuata l’operazione, la data e ora in cui e stata fatta l’operazione, l’account dell’utente e un Id tabella che identifica la tabella all’interno del database. Nella zona inferiore sono riportate tutte le colonne Inserite o modificate o cancellate dall’ operazione selezionata nella zona superione.

I dati visualizzati nella zona inferiore sono, il nome della colonna modificata, inserita o cancellata e l’eventuale vecchio valore e nuovo valore. In caso di Aggiornamenti vengono visualizzati solo le colonne modificate presentando entrambi i valori (prima e dopo la modifica) in caso di Inserimento vengono presentate tutte le colonne della tabella impostate però solo nella colonna “Nuovo valore”, in caso invece di un’operazione di cancellazione vengono sempre riportate tutte le colonne impostate della tabella ma nella colonna “Vecchio valore”.


Utenti

Permette di caricare e gestire gli utenti.

Per ciascun utente è necessario indicare il nome (nick name), il nome completo, la parola d’ordine, l’intervallo di validità lo stato di attivazione e l’account dbms utilizzato per la connessione al dbms.

È preferibile associare a ciascun utente un’account dbms differente in modo che la gestione del log sui dati, basata sugli account dbms, possa evidenziare le attività svolte da ciascun utente.

Durante la creazione dei gruppi di lavoro è necessario indicare per ciascun soggetto l’utente da utilizzare.


Titoli di studio ed onorari

Permette di caricare e gestire i titoli di studio e titoli onorari. I titoli sono enumerati automaticamente.

Per ciascun titolo è necessario indicare la sigla è la descrizione.

Ogni soggetto può aver associato un titolo.


Tipologia elementi dell’organigramma

Permette di caricare e gestire le tipologie della pianta organica. Le tipologie sono enumerate automaticamente.

Per ciascuna tipologia è necessario indicare la sigla è la descrizione.

Ogni elemento dell’organigramma è caratterizzato da una tipologia.


Stazioni di lavoro

Permette di caricare e gestire le stazioni di lavoro che utilizzano il back-office.

Per ciascuna postazione è necessario indicare il nome, come indicato durante la configurazione del computer, il nome esteso e la data di attivazione.

È possibile indicare anche l’indirizzo IP ed alcuni flag, attualmente non utilizzati, per l’aggiornamento delle procedure.

Durante l’esecuzione delle azioni viene indicata anche la postazione da cui proviene la richiesta.


Sedi operative

Permette di caricare e gestire le sedi operative ed il loro indirizzo. Le sedi sono enumerate progressivamente.

Nella gestione dell’organigramma è possibile indicare per ciascun elemento la sede operativa.


Regioni italiane

Permette di caricare e gestire le regioni. Per ciascuna regione è necessario indicare il codice e la descrizione.


Qualifiche professionali

Permette di caricare e gestire le qualifiche professionali. Per ciascuna qualifica è necessario indicare una sigla e la descrizione. Le qualifiche sono enumerate automaticamente.

Durante la definizione dei gruppi di lavoro è possibile indicare la qualifica professionale dei soggetti che lo compongono.


Province

Permette di caricare e gestire le province italiane.

Per ciascuna provincia è necessario indicare la sigla, la denominazione il codice istat e la regione di appartenenza.


Profili utente

Permette di caricare e gestire i profili utente. Per ciascun profilo è necessario indicare una sigla e la descrizione.

I profili sono associati agli utenti durante la gestione dell’Organigramma. Ogni profilo ha associato un’insieme di azioni che può svolgere in lettura e scrittura o in sola lettura.

Nella finestra sono mostrati gli utenti che sono correntemente associati al profilo.


Organigramma

Permette il caricamento e la gestione dell’organigramma aziendale.

Su ogni elemento dell’organigramma è possibile indicare la descrizione, la tipologia del nodo, la sede ed il piano dell’edificio (opzionali) in cui opera il gruppo di lavoro associato, la sigla che contraddistingue l’elemento il numero di telefono, il fax e l’indirizzo di posta elettronica istituzionali.

Inoltre consente di raggruppare alcuni soggetti in un gruppo di lavoro.

Ad ogni soggetto del gruppo di lavoro, selezionato dalla tabella dei soggetti, è associata la qualifica, un numero di telefono ed un indirizzo personale, un orario di ricevimento, un profilo utente, un account utente ed un calendario di lavoro settimanale.

Un soggetto può comparire in più gruppi di lavoro e può avere associati profili diversi o account utente diversi. Comunque in fase di login è necessario selezionare una tra le impostazioni effettuate.


Le nazioni

Permette di caricare e gestire le nazioni. Per ciascuna nazione necessario indicare la sigla, la descrizione ed il codice istat.

Inoltre è possibile indicare la descrizione della cittadinanza ed il codice Belfiore.


I soggetti

Permette di caricare e gestire i soggetti. I soggetti sono enumerati automaticamente. I soggetti possono avere anche natura giuridica.

Per ciascuno è necessario indicare il cognome (o Ragione sociale), il nome (o Ragione sociale aggiuntiva), l’indirizzo e la località di residenza, il sesso (o Ditta), il codice fiscale (la partita iva).

Inoltre è possibile indicare il titolo di studio, la nazionalità, il luogo e la data di nascita.


Gestione delle autorizzazioni sulle azioni

Permette di impostare i diritti di accesso sulle funzionalità offerte dall’applicativo a ciascun profilo utente.

Una volta che è stato selezionato un profilo utente è possibile visualizzare, nella parte inferiore della finestra, i diritti attribuiti su ciascuna funzione

ed eventualmente apportare dei cambiamenti. Su ciascuna funzione è possibile assegnare il diritto di lettura e scrittura, il diritto di sola lettura oppure nessun diritto.

Se ad un elemento dell’albero viene associato un diritto esso si propaga sul sottoalbero, a meno che i nodi figli non abbiano un diritto già impostato. In quest’ultimo caso i diritti impostati sono preservati.

È possibile rimuovere i diritti impostati.


Cronologia azioni utente

Permette di stampare l’elenco delle azioni svolte da un utente in un dato periodo di tempo.


Configurazione del database di sistema

Permette di cifrare il contenuto di alcune tabelle di sistema.

Una volta indicata una chiave nel campo ‘Numero di serie’ è possibile applicare la cifratura dei dati.

Al momento vengono cifrate le tabelle ‘Account dbms’ ed ‘Utenti’.

La cifratura dei dati può essere rimossa tramite il pulsante [Rimuovi].


Comuni d'Italia e città estere

Permette di registrare i Comuni italiani e le città estere.


Abilitazione del log sui dati

(Log Manager)

La seguente funzione abilita la possibilità di creare all’interno di un database utente la generazione di un sistema di log che permette di monitorare tutte le modifiche apportate al database stesso. Questo log è completamente configurabile dato che dà la possibilità di decidere da parte dell’amministratore del database su quali tabelle e su quali colonne attivare la generazione del log.

Questa funzione permette inizialmente la creazione sul database, in modo automatico, di tutte quelle strutture, (Tabelle, Stored Procedure, ecc…), necessarie al funzionamento del log sul database cliccando semplicemente sulla voce di menù “Inizializzazione / Crea la struttura dati del log”.

Una volta creata la struttura di base con la funzionalità “Inizializzazione / Inizializza la gestione del log sul database”, la funzione legge la struttura delle tabelle utente sul database e la inserisce in automatico nelle tabelle utilizzate dalla gestione del log.

A questo punto vengono visualizzate, sulla sinistra l’elenco delle tabelle del database e sulla destra l’elenco delle colonne che formano la tabella selezionata sulla sinistra.

Sulla sinistra vengono visualizzate le tabelle che sono contenute sul database, l’unico campo modificabile è la colonna “Attivo”. Questo campo se disattivato disabilita il log sull’intera tabella cancellando tutti i trigger relativi a quella tabella senza però modificare la configurazione del log per quella tabella. Riattivando la colonna sulla tabella automaticamente vengono ricreati tutti i trigger sulla tabella in base alla configurazione presente nella parte destra.

Nella parte destra abbiamo l’elenco delle colonne che formano la tabella e quattro colonne modificabili che permettono di decidere che tipologia di log vogliano su ogni singola colonna.

La sigla “I” sta per “Inserimento”, “U” per “Aggiornamento” , “D” per “Cancellazione” e “Idx” per “Indice di ricerca.

Se viene abilitata la colonna “I” nel log vengono registrate tutte le operazioni di inserimento, abilitando la colonna “U” tutte le operazioni di aggiornamento mentre con “D” tutte le cancellazioni di quella colonna naturalmente con tutte le informazioni su quale Operatore ha effettuato l’operazione e quando.

La colonna “Idx” invece sono le colonne per il quale l’amministratore può fare le operazioni di ricerca.

Nel momento in cui si modificano i parametri che riguardano le colonne viene abilitato il pulsante in basso a destra con la descrizione “Applica”, in questo stato l’operatore può solo modificare i parametri delle colonne della tabella selezionata e non potrà selezionare un’altra tabella fino alla conferma delle modifiche cliccando su “Applica” o sull’abbandono delle stesse con “Annulla”, in questo modo da riabilitare la parte destra per la selezione di un’altra tabella.


Licenze d'uso

Permette di registrare le licenze d’uso acquisite dal cliente. Sono enumerate le applicazioni e l’elenco dei rinnovi ed il dettaglio di ciascun rinnovo oltre ai moduli sottoscritti.

La finestra si limita a visualizzare i dati che sono aggiornati dalle procedure di rinnovo licenza d’uso.

Il referente della procedura, ovvero colui che ne detiene la responsabilità, attribuisce alle stazioni di lavoro il diritto ad installare l’applicazione ed ottenere gli aggiornamenti.


Calendario lavorativo settimanale

Permette di registrare i calendari di lavoro settimanale.

I calendari sono enumerati automaticamente. È necessario indicare la descrizione del calendario.

Per ciascun calendario è mostrato graficamente il calendario di lavoro settimanale.

Facendo doppio click con il mouse sull’orario è possibile caricare l’orario di lavoro per il giorno selezionato.

L’orario può essere spezzato in più turni nell’arco della giornata.


Account fisici

Permette di registrare gli account creati sul DBMS per la successiva associazione agli utenti logici.

Gli account fisici sono enumerati automaticamente. Il nome utente e la password sono obbligatori.